The following packages have unmet dependencies fix details

I was recently trying to install php5-curl and ran in to this error

# apt-get install php5-curl
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 mod-pagespeed-beta : Depends: apache2.2-common but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

How to fix error “The following packages have unmet dependencies fix”

Whatever package it is complaining about you must run apt-get remove… example:

# apt-get remove mod-pagespeed-beta
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  mod-pagespeed-beta
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 3924kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 44500 files and directories currently installed.)
Removing mod-pagespeed-beta ...
Last modified: May 2, 2012

Author

Comments

Write a Reply or Comment

Your email address will not be published.

To create code blocks or other preformatted text, indent by four spaces:

    This will be displayed in a monospaced font. The first four 
    spaces will be stripped off, but all other whitespace
    will be preserved.
    
    Markdown is turned off in code blocks:
     [This is not a link](http://example.com)

To create not a block, but an inline code span, use backticks:

Here is some inline `code`.

For more help see http://daringfireball.net/projects/markdown/syntax

This site uses Akismet to reduce spam. Learn how your comment data is processed.